In short
- CVE-2022-23080 is a MEDIUM (CVSS 5.0) vulnerability affecting directus (rangerstudio), directus.
- Chance of exploitation in the next 30 days (EPSS): 0.83%, higher than 57.4% of all vulnerabilities.
- Fix: update to 9.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| directus | = 9.0.0≥ 9.0.1, ≤ 9.6.0
| No fix yet |
| directus npm | ≥ 9.0.0-beta.2, < 9.7.0
| 9.7.0
|
Description
Directus versions v9.0.0-beta.2 through 9.6.0 are vulnerable to server-side request forgery (SSRF) in the media upload functionality, which allows a low privileged user to perform internal network port scans.
NVD description
In directus versions v9.0.0-beta.2 through 9.6.0 are vulnerable to server-side request forgery (SSRF) in the media upload functionality which allows a low privileged user to perform internal network port scans.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free