In short
- CVE-2023-27474 is a MEDIUM (CVSS 5.4) vulnerability affecting directus (rangerstudio), directus.
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.9% of all vulnerabilities.
- Fix: update to 9.23.0 or later.
| Package | Affected versions | Patched versions |
|---|
| directus | < 9.23.0
| 9.23.0
|
| directus npm | < 9.23.0
| 9.23.0
|
Description
Impact
Instances relying on an allow-listed reset URL are vulnerable to an HTML injection attack through the use of query parameters in the reset URL.
Patches
The problem has been resolved and released under version 9.23.0. People relying on a custom password reset URL should upgrade to 9.23.0 or later, or remove the custom reset url from the configured allow list.
Workarounds
Disable the custom reset URL allow list.
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. Instances relying on an allow-listed reset URL are vulnerable to an HTML injection attack through the use of query parameters in the reset URL. An attacker could exploit this to email users urls to the servers domain but which may contain malicious code. The problem has been resolved and released under version 9.23.0. People relying on a custom password reset URL should upgrade to 9.23.0 or later, or remove the custom reset url from the configured allow list. Users are advised to upgrade. Users unable to upgrade may disable the custom reset URL allow list as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free