In short
- CVE-2022-24825 is a MEDIUM (CVSS 5.3) vulnerability affecting github.com/stripe/smokescreen, smokescreen (stripe).
- Chance of exploitation in the next 30 days (EPSS): 0.93%, higher than 60.7% of all vulnerabilities.
- Fix: update to 0.0.3 or later.
Description
The primary use case for Smokescreen is to prevent server-side request forgery (SSRF) attacks in which external attackers leverage the behavior of applications to connect to or scan internal infrastructure.
Smokescreen also offers an option to deny access to additional (e.g., external) URLs by way of a deny list. There was an issue in Smokescreen that made it possible to bypass the deny list feature by appending a dot to the end of user-supplied URLs, or by providing input in a different letter case.
Recommendation
Upgrade Smokescreen to version 0.0.3 or later.
Acknowledgements
Thanks to Grzegorz Niedziela for reporting the issue.
For more information
Email us at [email protected]
NVD description
Smokescreen is a simple HTTP proxy that fogs over naughty URLs. The primary use case for Smokescreen is to prevent server-side request forgery (SSRF) attacks in which external attackers leverage the behavior of applications to connect to or scan internal infrastructure. Smokescreen also offers an option to deny access to additional (e.g., external) URLs by way of a deny list. There was an issue in Smokescreen that made it possible to bypass the deny list feature by appending a dot to the end of user-supplied URLs, or by providing input in a different letter case. Recommended to upgrade Smokescreen to version 0.0.3 or later.
More vulnerabilities in github.com/stripe/smokescreen
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free