In short
- CVE-2022-29188 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/stripe/smokescreen, smokescreen (stripe).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 58.9% of all vulnerabilities.
- Fix: update to 0.0.4 or later.
Description
Impact
The primary use case for Smokescreen is to prevent server-side request forgery (SSRF) attacks in which external attackers leverage the behavior of applications to connect to or scan internal infrastructure.
Smokescreen also offers an option to deny access to additional (e.g., external) URLs by way of a deny list. There was an issue in Smokescreen that made it possible to bypass the deny list feature by surrounding the hostname with square brackets (e.g. [example.com]).
Recommendation
Upgrade Smokescreen to version 0.0.4 or later.
Acknowledgements
Thanks to Axel Chong for reporting the issue.
For more information
Email us at [email protected]
NVD description
Smokescreen is an HTTP proxy. The primary use case for Smokescreen is to prevent server-side request forgery (SSRF) attacks in which external attackers leverage the behavior of applications to connect to or scan internal infrastructure. Smokescreen also offers an option to deny access to additional (e.g., external) URLs by way of a deny list. There was an issue in Smokescreen that made it possible to bypass the deny list feature by surrounding the hostname with square brackets (e.g. `[example.com]`). This only impacted the HTTP proxy functionality of Smokescreen. HTTPS requests were not impacted. Smokescreen version 0.0.4 contains a patch for this issue.
More vulnerabilities in github.com/stripe/smokescreen
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free