In short
- CVE-2022-25303 is a MEDIUM (CVSS 6.1) vulnerability affecting whoogle-search, whoogle-search (whoogle-search project).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.0% of all vulnerabilities.
- Fix: update to 0.7.2 or later.
Description
The package whoogle-search before version 0.7.2 is vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the flask.render_template function. However, the error_message is rendered using the | safe filter, meaning the user input is not escaped.
NVD description
The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.
More vulnerabilities in whoogle-search
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free