In short
- CVE-2022-25851 is a HIGH (CVSS 7.5) vulnerability affecting jpeg-js (jpeg-js project), jpeg-js.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.7% of all vulnerabilities.
- Fix: update to 0.4.4 or later.
| Package | Affected versions | Patched versions |
|---|
| jpeg-js | < 0.4.4
| 0.4.4
|
| jpeg-js npm | < 0.4.4
| 0.4.4
|
Description
The package jpeg-js before 0.4.4 is vulnerable to Denial of Service (DoS) where a particular piece of input will cause the program to enter an infinite loop and never return.
NVD description
The package jpeg-js before 0.4.4 are vulnerable to Denial of Service (DoS) where a particular piece of input will cause to enter an infinite loop and never return.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free