In short
- CVE-2022-25875 is a MEDIUM (CVSS 6.1) vulnerability affecting svelte (svelte), svelte.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 73.2% of all vulnerabilities.
- Fix: update to 3.49.0 or later.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 3.49.0
| 3.49.0
|
| svelte npm | < 3.49.0
| 3.49.0
|
Description
The package svelte before 3.49.0 is vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.
NVD description
The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free