In short
- CVE-2022-25978 is a MEDIUM (CVSS 6.1) vulnerability affecting github.com/usememos/memos.
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 45.1% of all vulnerabilities.
- Fix: update to 0.10.4-0.20230211093429-b11d2130a084 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/usememos/memos Go | < 0.10.4-0.20230211093429-b11d2130a084
| 0.10.4-0.20230211093429-b11d2130a084
|
Description
All versions of the package github.com/usememos/memos/server prior to 0.11.0 are vulnerable to Cross-site Scripting (XSS) due to insufficient checks on external resources, which allows malicious actors to introduce links starting with a javascript: scheme.
NVD description
All versions of the package github.com/usememos/memos/server are vulnerable to Cross-site Scripting (XSS) due to insufficient checks on external resources, which allows malicious actors to introduce links starting with a javascript: scheme.
More vulnerabilities in github.com/usememos/memos
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free