In short
- CVE-2022-29040 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.tools:git-parameter, git parameter (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.83%, higher than 57.6% of all vulnerabilities.
- Fix: update to 0.9.16 or later.
Description
Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD description
Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
More vulnerabilities in org.jenkins-ci.tools:git-parameter
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free