In short
- CVE-2022-29051 is a MEDIUM (CVSS 4.3) vulnerability affecting org.jenkins-ci.plugins:publish-over-ftp, publish over ftp (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.75%, higher than 55.0% of all vulnerabilities.
- Fix: update to 1.17 or later.
Description
Missing permission checks in Jenkins Publish Over FTP Plugin prior to 1.17 allow attackers with Overall/Read permission to connect to an FTP server using attacker-specified credentials.
NVD description
Missing permission checks in Jenkins Publish Over FTP Plugin 1.16 and earlier allow attackers with Overall/Read permission to connect to an FTP server using attacker-specified credentials.
More vulnerabilities in org.jenkins-ci.plugins:publish-over-ftp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free