In short
- CVE-2022-31145 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/flyteorg/flyteadmin, flyteadmin (flyte).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.8% of all vulnerabilities.
- Fix: update to 1.1.31 or later.
Description
Impact
Authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire.
Using flyteadmin as the OAuth2 Authorization Server is unaffected by this issue.
Patches
1.1.30
Workarounds
Rotating signing keys immediately will:
- Invalidate all open sessions,
- Force all users to attempt to obtain new tokens.
Continue to rotate keys until flyteadmin has been upgraded,
Hide flyteadmin deployment ingress url from the internet.
References
https://github.com/flyteorg/flyteadmin/pull/455
For more information
If you have any questions or comments about this advisory:
NVD description
FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. In versions 1.1.30 and prior, authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire. Users who use FlyteAdmin as the OAuth2 Authorization Server are unaffected by this issue. A patch is available on the `master` branch of the repository. As a workaround, rotating signing keys immediately will invalidate all open sessions and force all users to attempt to obtain new tokens. Those who use this workaround should continue to rotate keys until FlyteAdmin has been upgraded and hide FlyteAdmin deployment ingress URL from the internet.
More vulnerabilities in github.com/flyteorg/flyteadmin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free