In short
- CVE-2023-41891 is a HIGH (CVSS 8.8) vulnerability affecting github.com/flyteorg/flyteadmin, flyteadmin (flyte).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.5% of all vulnerabilities.
- Fix: update to 1.1.124 or later.
Description
Impact
List endpoints on Flyte Admin has a SQL vulnerability where a malicious user can send a REST requests with custom SQL statements as list filters.
Workarounds
The attacker needs to have access to the flyteadmin installation (typically either behind a VPN or authentication).
References
https://owasp.org/www-community/attacks/SQL_Injection#
NVD description
FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. Prior to version 1.1.124, list endpoints on FlyteAdmin have a SQL vulnerability where a malicious user can send a REST request with custom SQL statements as list filters. The attacker needs to have access to the FlyteAdmin installation, typically either behind a VPN or authentication. Version 1.1.124 contains a patch for this issue.
More vulnerabilities in github.com/flyteorg/flyteadmin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free