In short
- CVE-2022-43171 is a MEDIUM (CVSS 6.5) vulnerability affecting lief, lief (lief-project).
- Chance of exploitation in the next 30 days (EPSS): 0.72%, higher than 54.0% of all vulnerabilities.
- Fix: update to 0.12.3 or later.
| Package | Affected versions | Patched versions |
|---|
| lief PyPI | < 0.12.3
| 0.12.3
|
| lief | = 0.12.1
| No fix yet |
Description
A heap buffer overflow in the LIEF::MachO::BinaryParser::parse_dyldinfo_generic_bind function of LIEF prior to version 0.12.3 allows attackers to cause a Denial of Service (DoS) via a crafted MachO file.
NVD description
A heap buffer overflow in the LIEF::MachO::BinaryParser::parse_dyldinfo_generic_bind function of LIEF v0.12.1 allows attackers to cause a Denial of Service (DoS) via a crafted MachO file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free