In short
- CVE-2024-31636 is a LOW (CVSS 3.9) vulnerability affecting lief, lief (lief-project).
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.2% of all vulnerabilities.
- Fix: update to 0.15.0 or later.
| Package | Affected versions | Patched versions |
|---|
| lief PyPI | ≤ 0.14.1< 0.15.0
| 0.15.0
|
| lief | = 0.14.1
| No fix yet |
Description
An issue in LIEF v.0.14.1 allows a local attacker to obtain sensitive information via the name parameter of the machd_reader.c component.
NVD description
An issue in LIEF v.0.14.1 allows a local attacker to obtain sensitive information via the name parameter of the machd_reader.c component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free