In short
- CVE-2022-44644 is a MEDIUM (CVSS 6.5) vulnerability affecting org.apache.linkis:linkis, linkis (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.2% of all vulnerabilities.
- Fix: update to 1.3.1 or later.
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, an authenticated attacker could read arbitrary local file by connecting a rogue mysql server, By adding allowLoadLocalInfile to true in the jdbc parameter. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.1
NVD description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J in the data source module, an authenticated attacker could read arbitrary local files by connecting a rogue MySQL server, By adding allowLoadLocalInfile to true in the JDBC parameter. Therefore, the parameters in the JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.3.1
More vulnerabilities in org.apache.linkis:linkis
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free