In short
- CVE-2022-44645 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.linkis:linkis, linkis (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.1% of all vulnerabilities.
- Fix: update to 1.3.1 or later.
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
NVD description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users to upgrade the version of Linkis to version 1.3.1.
More vulnerabilities in org.apache.linkis:linkis
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free