In short
- CVE-2023-23638 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.dubbo:dubbo, dubbo (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.8%, higher than 92.0% of all vulnerabilities.
- Fix: update to 3.0.13, 3.1.5, 2.7.22 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.dubbo:dubbo Maven | ≥ 3.0.0, < 3.0.13≥ 3.1.0, < 3.1.5< 2.7.22
| 3.0.133.1.52.7.22
|
| dubbo | ≥ 2.7.0, ≤ 2.7.21≥ 3.0.0, ≤ 3.0.13≥ 3.1.0, ≤ 3.1.5
| No fix yet |
Description
A deserialization vulnerability existed when dubbo generic invoke, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.21 and prior versions; Apache Dubbo 3.0.x version 3.0.13 and prior versions; Apache Dubbo 3.1.x version 3.1.5 and prior versions.
NVD description
A deserialization vulnerability existed when dubbo generic invoke, which could lead to malicious code execution.
This issue affects Apache Dubbo 2.7.x version 2.7.21 and prior versions; Apache Dubbo 3.0.x version 3.0.13 and prior versions; Apache Dubbo 3.1.x version 3.1.5 and prior versions.
More vulnerabilities in org.apache.dubbo:dubbo
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free