In short
- CVE-2023-25170 is a HIGH (CVSS 8.8) vulnerability affecting prestashop/prestashop, prestashop (prestashop).
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 12.3% of all vulnerabilities.
- Fix: update to 8.0.1 or later.
Description
Impact
When authenticating users PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation.
Patches
The problem is fixed in version 8.0.1
NVD description
PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.
More vulnerabilities in prestashop/prestashop
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free