In short
- CVE-2023-25765 is a CRITICAL (CVSS 9.9) vulnerability affecting org.jenkins-ci.plugins:email-ext, email extension (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.5% of all vulnerabilities.
- Fix: update to 2.94, 2.93.1 or later.
Description
In Jenkins Email Extension Plugin 2.93 and earlier, templates defined inside a folder were not subject to Script Security protection, allowing attackers able to define email templates in folders to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
NVD description
In Jenkins Email Extension Plugin 2.93 and earlier, templates defined inside a folder were not subject to Script Security protection, allowing attackers able to define email templates in folders to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
More vulnerabilities in org.jenkins-ci.plugins:email-ext
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free