In short
- CVE-2023-27582 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/foxcpp/maddy, maddy (maddy project).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.5% of all vulnerabilities.
- Fix: update to 0.6.3 or later.
Description
Impact
maddy 0.2.0 - 0.6.2 allows a full authentication bypass if SASL authorization username is specified when using the PLAIN authentication mechanisms. Instead of validating the specified authorization username, it is accepted as is after checking the credentials for the authentication username.
Patches
maddy 0.6.3 includes the fix for the bug.
Workarounds
There is no way to fix the issue without upgrading.
References
NVD description
maddy is a composable, all-in-one mail server. Starting with version 0.2.0 and prior to version 0.6.3, maddy allows a full authentication bypass if SASL authorization username is specified when using the PLAIN authentication mechanisms. Instead of validating the specified username, it is accepted as is after checking the credentials for the authentication username. maddy 0.6.3 includes the fix for the bug. There are no known workarounds.
More vulnerabilities in github.com/foxcpp/maddy
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free