In short
- CVE-2023-27602 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.linkis:linkis, linkis (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.8% of all vulnerabilities.
- Fix: update to 1.3.2 or later.
Description
In Apache Linkis <=1.3.1, The PublicService module uploads files without restrictions on the path to the uploaded files, and file types.
We recommend users upgrade the version of Linkis to version 1.3.2.
For versions <=1.3.1, we suggest turning on the file path check switch in linkis.properties
wds.linkis.workspace.filesystem.owner.check=true
wds.linkis.workspace.filesystem.path.check=true
NVD description
In Apache Linkis <=1.3.1, The PublicService module uploads files without restrictions on the path to the uploaded files, and file types.
We recommend users upgrade the version of Linkis to version 1.3.2.
For versions
<=1.3.1, we suggest turning on the file path check switch in linkis.properties
`wds.linkis.workspace.filesystem.owner.check=true`
`wds.linkis.workspace.filesystem.path.check=true`
More vulnerabilities in org.apache.linkis:linkis
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free