In short
- CVE-2023-29824 is a CRITICAL (CVSS 9.8) vulnerability affecting scipy, scipy (scipy).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.5% of all vulnerabilities.
- Fix: update to 1.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| scipy PyPI | < 1.8.0
| 1.8.0
|
| scipy | < 1.8.0
| 1.8.0
|
Description
Withdrawn Advisory
This advisory has been withdrawn because it has been found to not be an issue. Please see the issue here for more information.
Original Description
A use-after-free issue was discovered in Py_FindObjects() function in SciPy versions prior to 1.8.0.
NVD description
A use-after-free issue was discovered in Py_FindObjects() function in SciPy versions prior to 1.8.0. NOTE: the vendor and discoverer indicate that this is not a security issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free