In short
- CVE-2023-31098 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.inlong:manager-pojo, inlong (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.0% of all vulnerabilities.
- Fix: update to 1.47.0 or later.
Description
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.1.0 through 1.6.0. When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 to solve it.
NVD description
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0.
When users change their password to a simple password (with any character or
symbol), attackers can easily guess the user's password and access the account.
Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.
More vulnerabilities in org.apache.inlong:manager-pojo
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free