In short
- CVE-2023-33264 is a MEDIUM (CVSS 4.3) vulnerability affecting com.hazelcast:hazelcast, hazelcast (hazelcast).
- Chance of exploitation in the next 30 days (EPSS): 0.72%, higher than 53.9% of all vulnerabilities.
- Fix: update to 5.0.5, 5.1.6, 5.2.4, 5.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| com.hazelcast:hazelcast Maven | ≥ 4.0-BETA-1, ≤ 4.2.8≥ 5.0-BETA-1, < 5.0.5≥ 5.1-BETA-1, < 5.1.6≥ 5.2-BETA-1, < 5.2.4≥ 5.3.0-BETA-1, < 5.3.0
| 5.0.55.1.65.2.45.3.0
|
| hazelcast | ≥ 5.1, < 5.1.6≥ 5.2, ≤ 5.2.3≤ 5.0.4
| 5.1.6
|
Description
In Hazelcast before 5.3.0, configuration routines don't mask passwords in the member configuration properly. This allows Hazelcast Management Center users to view some of the secrets.
NVD description
In Hazelcast through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, configuration routines don't mask passwords in the member configuration properly. This allows Hazelcast Management Center users to view some of the secrets.
More vulnerabilities in com.hazelcast:hazelcast
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free