| Package | Affected versions | Patched versions |
|---|---|---|
| com.hazelcast:hazelcast | ≥ 5.5.0, < 5.7.0≥ 5.6.0, < 5.7.0< 5.7.0 | 5.7.0 |
Missing authorization checks in the Predicates API may allow a malicious client to execute arbitrary code on a Hazelcast member.
Enterprise customers should upgrade to a fixed version of Hazelcast Enterprise Edition:
Customers with extended support contracts should contact Hazelcast Support for information on patches for older versions.
Community Edition users should upgrade to version 5.7.0.
None - customers are advised to upgrade to a fixed version as soon as possible.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free