In short
- CVE-2023-34239 is a CRITICAL (CVSS 9.1) vulnerability affecting gradio, gradio (gradio project).
- Chance of exploitation in the next 30 days (EPSS): 0.65%, higher than 51.2% of all vulnerabilities.
- Fix: update to 3.34.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gradio PyPI | < 3.34.0
| 3.34.0
|
| gradio | < 3.34.0
| 3.34.0
|
Description
Impact
There are two separate security vulnerabilities here: (1) a security vulnerability that allows users to read arbitrary files on the machines that are running shared Gradio apps (2) the ability of users to use machines that are sharing Gradio apps to proxy arbitrary URLs
Patches
Both problems have been solved, please upgrade gradio to 3.34.0 or higher
Workarounds
Not possible to workaround except by taking down any shared Gradio apps
References
Relevant PRs:
NVD description
Gradio is an open-source Python library that is used to build machine learning and data science. Due to a lack of path filtering Gradio does not properly restrict file access to users. Additionally Gradio does not properly restrict the what URLs are proxied. These issues have been addressed in version 3.34.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free