In short
- CVE-2023-39526 is a CRITICAL (CVSS 9.8) vulnerability affecting prestashop/prestashop, prestashop (prestashop).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.1% of all vulnerabilities.
- Fix: update to 8.0.5, 8.1.1, 1.7.8.10 or later.
| Package | Affected versions | Patched versions |
|---|
| prestashop/prestashop Packagist | ≥ 8.0.0, < 8.0.5≥ 8.1.0, < 8.1.1< 1.7.8.10
| 8.0.58.1.11.7.8.10
|
| prestashop | = 8.1.0≥ 8.0.0, < 8.0.5< 1.7.8.10
| 8.0.51.7.8.10
|
Description
Impact
Remote code execution through SQL injection and arbitrary file write in back office
Patches
1.7.8.10
8.0.5
8.1.1
Found by
Truff (via yeswehack)
Workarounds
none
References
none
NVD description
PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to remote code execution through SQL injection and arbitrary file write in the back office. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.
More vulnerabilities in prestashop/prestashop
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free