In short
- CVE-2023-43664 is a MEDIUM (CVSS 4.3) vulnerability affecting prestashop/prestashop, prestashop (prestashop).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.6% of all vulnerabilities.
- Fix: update to 8.1.2 or later.
Description
Impact
In BO, an employee can list all modules without any access rights: method ajaxProcessGetPossibleHookingListForModule doesn't check access rights
Patches
Fixed on 8.1.2
Workarounds
References
NVD description
PrestaShop is an Open Source e-commerce web application. In the Prestashop Back office interface, an employee can list all modules without any access rights: method `ajaxProcessGetPossibleHookingListForModule` doesn't check access rights. This issue has been addressed in commit `15bd281c` which is included in version 8.1.2. Users are advised to upgrade. There are no known workaround for this issue.
More vulnerabilities in prestashop/prestashop
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free