In short
- CVE-2023-50725 is a MEDIUM (CVSS 6.1) vulnerability affecting resque, resque (resque).
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.7% of all vulnerabilities.
- Fix: update to 2.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| resque RubyGems | < 2.2.1
| 2.2.1
|
| resque | < 2.2.1
| 2.2.1
|
Description
Impact
The following paths in resque-web have been found to be vulnerable to reflected XSS:
/failed/?class=<script>alert(document.cookie)</script>
/queues/><img src=a onerror=alert(document.cookie)>
Patches
v2.2.1
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
https://github.com/resque/resque/pull/1790
NVD description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. The following paths in resque-web have been found to be vulnerable to reflected XSS: "/failed/?class=<script>alert(document.cookie)</script>" and "/queues/><img src=a onerror=alert(document.cookie)>". This issue has been patched in version 2.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free