In short
- CVE-2023-50727 is a MEDIUM (CVSS 6.1) vulnerability affecting resque, resque (resque).
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 44.0% of all vulnerabilities.
- Fix: update to 2.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| resque RubyGems | < 2.6.0
| 2.6.0
|
| resque | < 2.6.0
| 2.6.0
|
Description
Impact
Reflected XSS can be performed using the current_queue portion of the path on the /queues endpoint of resque-web.
Patches
v2.6.0
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
https://github.com/resque/resque/pull/1865
NVD description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. Reflected XSS issue occurs when /queues is appended with /"><svg%20onload=alert(domain)>. This issue has been patched in version 2.6.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free