In short
- CVE-2024-10833 is a CRITICAL (CVSS 9.1) vulnerability affecting dbgpt, db-gpt (dbgpt).
- Chance of exploitation in the next 30 days (EPSS): 0.84%, higher than 57.9% of all vulnerabilities.
- Fix: update to 0.6.2 or later.
| Package | Affected versions | Patched versions |
|---|
| dbgpt PyPI | < 0.6.2
| 0.6.2
|
| db-gpt | = 0.6.0
| No fix yet |
Description
eosphoros-ai/db-gpt version 0.6.0 is vulnerable to an arbitrary file write through the knowledge API. The endpoint for uploading files as 'knowledge' is susceptible to absolute path traversal, allowing attackers to write files to arbitrary locations on the target server. This vulnerability arises because the 'doc_file.filename' parameter is user-controllable, enabling the construction of absolute paths.
NVD description
eosphoros-ai/db-gpt version 0.6.0 is vulnerable to an arbitrary file write through the knowledge API. The endpoint for uploading files as 'knowledge' is susceptible to absolute path traversal, allowing attackers to write files to arbitrary locations on the target server. This vulnerability arises because the 'doc_file.filename' parameter is user-controllable, enabling the construction of absolute paths.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free