In short
- CVE-2024-10835 is a CRITICAL (CVSS 9.8) vulnerability affecting dbgpt, db-gpt (dbgpt).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.8% of all vulnerabilities.
- Fix: update to 0.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| dbgpt PyPI | < 0.7.1
| 0.7.1
|
| db-gpt | = 0.6.0
| No fix yet |
Description
In eosphoros-ai/db-gpt version v0.6.0, the web API POST /api/v1/editor/sql/run allows execution of arbitrary SQL queries without any access control. This vulnerability can be exploited by attackers to perform Arbitrary File Write using DuckDB SQL, enabling them to write arbitrary files to the victim's file system. This can potentially lead to Remote Code Execution (RCE).
NVD description
In eosphoros-ai/db-gpt version v0.6.0, the web API `POST /api/v1/editor/sql/run` allows execution of arbitrary SQL queries without any access control. This vulnerability can be exploited by attackers to perform Arbitrary File Write using DuckDB SQL, enabling them to write arbitrary files to the victim's file system. This can potentially lead to Remote Code Execution (RCE).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free