In short
- CVE-2024-11079 is a MEDIUM (CVSS 5.5) vulnerability affecting ansible-core.
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.7% of all vulnerabilities.
- Fix: update to 2.17.7rc1, 2.18.1rc1, 2.16.14rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible-core PyPI | ≥ 2.17.0b1, < 2.17.7rc1≥ 2.18.0b1, < 2.18.1rc1< 2.16.14rc1
| 2.17.7rc12.18.1rc12.16.14rc1
|
Description
A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.
NVD description
A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.
More vulnerabilities in ansible-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free