In short
- CVE-2024-8775 is a MEDIUM (CVSS 5.5) vulnerability affecting ansible-core.
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.4% of all vulnerabilities.
- Fix: update to 2.17.6, 2.16.13 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible-core PyPI | ≥ 2.17.0b1, < 2.17.6< 2.16.13
| 2.17.62.16.13
|
Description
A flaw was found in Ansible, where sensitive information stored in Ansible Vault files can be exposed in plaintext during the execution of a playbook. This occurs when using tasks such as include_vars to load vaulted variables without setting the no_log: true parameter, resulting in sensitive data being printed in the playbook output or logs. This can lead to the unintentional disclosure of secrets like passwords or API keys, compromising security and potentially allowing unauthorized access or actions.
NVD description
A flaw was found in Ansible, where sensitive information stored in Ansible Vault files can be exposed in plaintext during the execution of a playbook. This occurs when using tasks such as include_vars to load vaulted variables without setting the no_log: true parameter, resulting in sensitive data being printed in the playbook output or logs. This can lead to the unintentional disclosure of secrets like passwords or API keys, compromising security and potentially allowing unauthorized access or actions.
More vulnerabilities in ansible-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free