In short
- CVE-2024-1681 is a MEDIUM (CVSS 5.3) vulnerability affecting flask-cors, flask-cors (corydolphin).
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.6% of all vulnerabilities.
- Fix: update to 4.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| flask-cors PyPI | ≤ 4.0.0< 4.0.1
| 4.0.1
|
| flask-cors | = 4.0.0
| No fix yet |
Description
corydolphin/flask-cors is vulnerable to log injection when the log level is set to debug. An attacker can inject fake log entries into the log file by sending a specially crafted GET request containing a CRLF sequence in the request path. This vulnerability allows attackers to corrupt log files, potentially covering tracks of other attacks, confusing log post-processing tools, and forging log entries. The issue is due to improper output neutralization for logs.
NVD description
corydolphin/flask-cors is vulnerable to log injection when the log level is set to debug. An attacker can inject fake log entries into the log file by sending a specially crafted GET request containing a CRLF sequence in the request path. This vulnerability allows attackers to corrupt log files, potentially covering tracks of other attacks, confusing log post-processing tools, and forging log entries. The issue is due to improper output neutralization for logs.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free