In short
- CVE-2024-6221 is a HIGH (CVSS 7.5) vulnerability affecting flask-cors, flask-cors (corydolphin).
- Chance of exploitation in the next 30 days (EPSS): 0.72%, higher than 53.9% of all vulnerabilities.
- Fix: update to 4.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| flask-cors PyPI | ≤ 4.0.1< 4.0.2
| 4.0.2
|
| flask-cors | = 4.0.1
| No fix yet |
Description
A vulnerability in corydolphin/flask-cors version 4.0.1 allows the Access-Control-Allow-Private-Network CORS header to be set to true by default, without any configuration option. This behavior can expose private network resources to unauthorized external access, leading to significant security risks such as data breaches, unauthorized access to sensitive information, and potential network intrusions.
NVD description
A vulnerability in corydolphin/flask-cors version 4.0.1 allows the `Access-Control-Allow-Private-Network` CORS header to be set to true by default. This behavior can expose private network resources to unauthorized external access, leading to significant security risks such as data breaches, unauthorized access to sensitive information, and potential network intrusions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free