In short
- CVE-2024-21627 is a MEDIUM (CVSS 6.1) vulnerability affecting prestashop/prestashop, prestashop (prestashop).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.4% of all vulnerabilities.
- Fix: update to 8.1.3, 1.7.8.11 or later.
| Package | Affected versions | Patched versions |
|---|
| prestashop/prestashop Packagist | ≥ 8.0.0-beta.1, < 8.1.3< 1.7.8.11
| 8.1.31.7.8.11
|
| prestashop | ≥ 8.0.0, < 8.1.3< 1.7.8.11
| 8.1.31.7.8.11
|
Description
Description
Some event attributes are not detected by the isCleanHTML method
Impact
Some modules using the isCleanHTML method could be vulnerable to xss
Patches
8.1.3, 1.7.8.11
Workarounds
The best workaround is to use the HTMLPurifier library to sanitize html input coming from users. The library is already available as a dependency in the PrestaShop project. Beware though that in legacy object models, fields of HTML type will call isCleanHTML.
Reporters
Reported by Antonio Russo (@Antonio-R1 on GitHub) and Antonio Rocco Spataro (@antoniospataro on GitHub).
NVD description
PrestaShop is an open-source e-commerce platform. Prior to versions 8.1.3 and 1.7.8.11, some event attributes are not detected by the `isCleanHTML` method. Some modules using the `isCleanHTML` method could be vulnerable to cross-site scripting. Versions 8.1.3 and 1.7.8.11 contain a patch for this issue. The best workaround is to use the `HTMLPurifier` library to sanitize html input coming from users. The library is already available as a dependency in the PrestaShop project. Beware though that in legacy object models, fields of `HTML` type will call `isCleanHTML`.
More vulnerabilities in prestashop/prestashop
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free