In short
- CVE-2024-24590 is a HIGH (CVSS 8.8) vulnerability affecting clearml, clearml (clear).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.6% of all vulnerabilities.
- Fix: update to 1.14.3rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| clearml PyPI | ≥ 0.17.0, ≤ 1.14.1≥ 0.17.0, < 1.14.3rc0
| 1.14.3rc0
|
| clearml | ≥ 0.17.0, ≤ 1.14.2
| No fix yet |
Description
Deserialization of untrusted data can occur in versions 0.17.0 to 1.14.2 of the client SDK of Allegro AI’s ClearML platform, enabling a maliciously uploaded artifact to run arbitrary code on an end user’s system when interacted with.
NVD description
Deserialization of untrusted data can occur in versions 0.17.0 to 1.14.2 of the client SDK of Allegro AI’s ClearML platform, enabling a maliciously uploaded artifact to run arbitrary code on an end user’s system when interacted with.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free