In short
- CVE-2025-8917 is a MEDIUM (CVSS 5.8) vulnerability affecting clearml.
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.8% of all vulnerabilities.
- Fix: update to 2.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| clearml PyPI | < 2.0.2
| 2.0.2
|
Description
A vulnerability in clearml versions before 2.0.2 allows for path traversal due to improper handling of symbolic and hard links in the safe_extract function. This flaw can lead to arbitrary file writes outside the intended directory, potentially resulting in remote code execution if critical files are overwritten.
NVD description
A vulnerability in allegroai/clearml version v2.0.1 allows for path traversal due to improper handling of symbolic and hard links in the `safe_extract` function. This flaw can lead to arbitrary file writes outside the intended directory, potentially resulting in remote code execution if critical files are overwritten.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free