In short
- CVE-2024-31580 is a MEDIUM (CVSS 4.0) vulnerability affecting torch, torch-npu, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 13.2% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.2.0
| 2.2.0
|
| torch-npu PyPI | < 2.2.0
| 2.2.0
|
| pytorch | < 2.2.0
| 2.2.0
|
Description
PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.
NVD description
PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free