In short
- CVE-2024-31583 is a HIGH (CVSS 7.8) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.0% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.2.0
| 2.2.0
|
| pytorch | < 2.2.0
| 2.2.0
|
Description
Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.
NVD description
Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free