In short
- CVE-2024-31584 is a MEDIUM (CVSS 5.5) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 32.4% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.2.0
| 2.2.0
|
| pytorch | < 2.2.0
| 2.2.0
|
Description
Pytorch before v2.2.0 has an Out-of-bounds Read vulnerability via the component torch/csrc/jit/mobile/flatbuffer_loader.cpp.
NVD description
Pytorch before v2.2.0 has an Out-of-bounds Read vulnerability via the component torch/csrc/jit/mobile/flatbuffer_loader.cpp.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free