In short
- CVE-2024-34391 is a CRITICAL (CVSS 9.8) vulnerability affecting libxmljs (libxmljs project), libxmljs.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.1% of all vulnerabilities.
- Fix: update to 1.0.11 or later.
| Package | Affected versions | Patched versions |
|---|
| libxmljs | < 1.0.11
| 1.0.11
|
| libxmljs npm | ≤ 1.0.11
| No fix yet |
Description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking a function on the result of attrs() that was called on a parsed node. This vulnerability might lead to denial of service (on both 32-bit systems and 64-bit systems), data leak, infinite loop and remote code execution (on 32-bit systems with the XML_PARSE_HUGE flag enabled).
NVD description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking a function on the result of attrs() that was called on a parsed node. This vulnerability might lead to denial of service (on both 32-bit systems and 64-bit systems), data leak, infinite loop and remote code execution (on 32-bit systems with the XML_PARSE_HUGE flag enabled).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free