In short
- CVE-2024-34392 is a CRITICAL (CVSS 9.8) vulnerability affecting libxmljs (libxmljs project), libxmljs.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.6% of all vulnerabilities.
- Fix: update to 1.0.11 or later.
| Package | Affected versions | Patched versions |
|---|
| libxmljs | < 1.0.11
| 1.0.11
|
| libxmljs npm | ≤ 1.0.11
| No fix yet |
Description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking the namespaces() function (which invokes _wrap__xmlNode_nsDef_get()) on a grand-child of a node that refers to an entity. This vulnerability can lead to denial of service and remote code execution.
NVD description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking the namespaces() function (which invokes _wrap__xmlNode_nsDef_get()) on a grand-child of a node that refers to an entity. This vulnerability can lead to denial of service and remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free