| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui | ≥ 2.1.0, < 3.0.8 | 3.0.8 |
| org.apache.syncope.client.idrepo:syncope-client-idrepo-console | ≥ 2.1.0, < 3.0.8 | 3.0.8 |
| syncope | ≥ 2.1.0, ≤ 2.1.14≥ 3.0.0, < 3.0.8 | 3.0.8 |
When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing "Personal Information" or "User Requests".
Users are recommended to upgrade to version 3.0.8, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free