In short
- CVE-2024-44314 is a MEDIUM (CVSS 6.5) vulnerability affecting tastyigniter/tastyigniter, tastyigniter (tastyigniter).
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.9% of all vulnerabilities.
- Fix: update to 4.0.0 or later.
Description
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
NVD description
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
More vulnerabilities in tastyigniter/tastyigniter
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free