In short
- CVE-2024-45858 is a HIGH (CVSS 7.8) vulnerability affecting guardrails-ai.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 31.8% of all vulnerabilities.
- Fix: update to 0.5.10 or later.
| Package | Affected versions | Patched versions |
|---|
| guardrails-ai PyPI | ≥ 0.2.9, < 0.5.10
| 0.5.10
|
Description
An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.
NVD description
An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.
More vulnerabilities in guardrails-ai
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free