In short
- CVE-2024-6961 is a MEDIUM (CVSS 5.9) vulnerability affecting guardrails-ai.
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.1% of all vulnerabilities.
- Fix: update to 0.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| guardrails-ai PyPI | < 0.5.0
| 0.5.0
|
Description
RAIL documents are an XML-based format invented by Guardrails AI to enforce formatting checks on LLM outputs. Guardrails users that consume RAIL documents from external sources are vulnerable to XXE, which may cause leakage of internal file data via the SYSTEM entity.
NVD description
RAIL documents are an XML-based format invented by Guardrails AI to enforce formatting checks on LLM outputs. Guardrails users that consume RAIL documents from external sources are vulnerable to XXE, which may cause leakage of internal file data via the SYSTEM entity.
More vulnerabilities in guardrails-ai
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free