In short
- CVE-2024-48063 is a CRITICAL (CVSS 9.8) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 76.0% of all vulnerabilities.
- Fix: update to 2.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.5.0
| 2.5.0
|
| pytorch | ≤ 2.4.1
| No fix yet |
Description
In PyTorch <=2.4.1, the RemoteModule has Deserialization RCE. NOTE: this is disputed by multiple parties because this is intended behavior in PyTorch distributed computing.
NVD description
In PyTorch <=2.4.1, the RemoteModule has Deserialization RCE. NOTE: this is disputed by multiple parties because this is intended behavior in PyTorch distributed computing.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free