In short
- CVE-2024-8183 is a HIGH (CVSS 7.6) vulnerability affecting prefect.
- Chance of exploitation in the next 30 days (EPSS): 0.18%, higher than 8.0% of all vulnerabilities.
- Fix: update to 3.0.3, 2.20.17 or later.
| Package | Affected versions | Patched versions |
|---|
| prefect PyPI | ≥ 3.0.0rc1, < 3.0.3< 2.20.17
| 3.0.32.20.17
|
Description
A CORS (Cross-Origin Resource Sharing) misconfiguration in prefecthq/prefect prior to version 3.0.3 allows unauthorized domains to access sensitive data. This vulnerability can lead to unauthorized access to the database, resulting in potential data leaks, loss of confidentiality, service disruption, and data integrity risks.
NVD description
A CORS (Cross-Origin Resource Sharing) misconfiguration in prefecthq/prefect version 2.20.2 allows unauthorized domains to access sensitive data. This vulnerability can lead to unauthorized access to the database, resulting in potential data leaks, loss of confidentiality, service disruption, and data integrity risks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free